No pressure....can't figure out why!

9 months 2 hours ago #3387 by robweatherfan

I have a Generac pressure washer, about 2700 psi. Last summer lost all pressure. About same time engine began surging (up and down rpm's) while idiling. Replaced unloader valve and still no pressure. Later, in fall, still surging at times and even not running, at times, without choke being part way on.
Recently I took apart and cleaned the carburetor. It looked pretty clean when I got in there, but I think it helped. Now runs with very little surge and without choke applied. It even produced pressure for a few seconds before it ran out of gas, but now no pressure again!
When engine is running and there is no pressure I hear some rattling in area of the pump.

If anyone has any ideas, please help!

Please JLOGIN or Create an account to join the conversation.

8 months 4 weeks ago #3388 by MTR-Admin

What type of gun do you have? Also, do you have the model number?

Please JLOGIN or Create an account to join the conversation.

8 months 3 weeks ago #3390 by robweatherfan

Thank you Administrator for replying, but I'm ok now.
I took the pump off of the engine shaft and was able to spin the pump "shaft" freely....no grinding or noise. I also took the unloader valve out of its seat, but I doubt this affected anything since the unloader valve is new. Also, there's a very narrow, inch long piece of metal that fits into a groove on the engine shaft where the pump slides over it. That fell out and I slid it back in.

When I put it back together it worked! I used it for over 30 minutes.
Feel free to let me know if you have any idea what the problem could have been.

I gained some good experience along the way for future repair work!:)

Please JLOGIN or Create an account to join the conversation.

8 months 3 weeks ago #3391 by MTR-Admin

Great, glad to hear that you found the problem. That piece of metal is called a 'key'.
Happy new year.

Please JLOGIN or Create an account to join the conversation.

8 months 2 weeks ago #3399 by robweatherfan

Hey, thanks for the key info. Hope you had a good New Year holiday.
Maybe talk to you on my next forum question.

Please JLOGIN or Create an account to join the conversation.

Moderators: MTR-Admin
Time to create page: 0.106 seconds