Scroll saw sparked then didn't work

8 years 4 months ago #1390 by pbesong
Scroll saw sparked then didn't work was created by pbesong
I have a pretty old scroll saw that i bought used. I used it a few times then the last time I used it it made a spark, then it stopped working completely. Is this something repairable, like a brush on the motor or something or should I just trash it? Hate to throw it out if it's a relatively easy fix.

Please Log in or Create an account to join the conversation.

8 years 4 months ago #1391 by pbesong
Replied by pbesong on topic Scroll saw sparked then didn't work
I figured it out. There was an old cut in the main wire that goes to the switch. I cut the wire and re-soldered it back together and now it works again. woot! Odd that the spark was occurring in the motor area when it went out so I was a bit surprised that fixing the power wire made it work again.

Please Log in or Create an account to join the conversation.

8 years 4 months ago #1396 by MTR-Admin
Replied by MTR-Admin on topic Scroll saw sparked then didn't work
Thanks for the post!

Sorry I showed up late, but yes...I was going to suggest that either the Brushes are worn, the armature commutator needs to be cleaned or that you have a short in a wire or a wire is damaged.

And, you didn't have to spend the $ to replace any parts...good deal!

- MTR

Please Log in or Create an account to join the conversation.

8 years 4 months ago #1398 by pbesong
Replied by pbesong on topic Scroll saw sparked then didn't work
thanks MTR. yeah, I was disappointed that it died so soon after i bought it. these older tools are usually pretty well made. never thought to look at the main wire, but just happened to notice it as I was messing with the motor. looked like an old cut in the insulation. all is well now. :-)

Please Log in or Create an account to join the conversation.

Moderators: MTR-Admin
Time to create page: 0.098 seconds