Coleman Powermate CL0502710 breaks circuit when restarting at low pressure limit

3 weeks 3 days ago #3326 by tessex

I purchased this new 20 yrs ago. Has always been dependable. Recently one of the springs on the rotary switch broke causing clatter. I replaced the springs with new ones and the compressor starts just fine. Will fill to 120 max pressure, bleeds off for 3-4 seconds, holds air with no leaks. When you use it, and it gets to the 90psi low, it tries to start but can't make it, blowing the circuit. I took it apart and cleaned the check valve, everything looked good. Can the check valve be bad and not make any noise?
I did notice inside the switch, I'm assuming the wire to the start circuit, has overheated a bit at some point and doesn't seem to be the full size of the other wire blade. Could this be the cause? Or an effect of the cause?
This has always been a good compressor and I would like to keep it running, but the pressure switch cost is exorbitant as well as the check valve being way more that it should be. To replace just those 2 items I could buy a new compressor for not much more.
I'm hoping someone can help me keep this alive. Any input is appreciated.
Thanks

Attachments:

Please Log in or Create an account to join the conversation.

3 weeks 2 days ago #3330 by MTR-Admin

When you say "rotary switch", do you mean the motor centrifugal switch or he start capacitor?
If so, I would use this troubleshooting tip sheet below.

mastertoolrepair.com/images/Motor_Problems.pdf

Please Log in or Create an account to join the conversation.

Moderators: MTR-Admin
Time to create page: 0.079 seconds