US General Model US66V Unloader Problem

2 years 9 months ago #3561 by Larryd
I have a US General Model US66V With an ongoing unloader issue.  Some time back the unloader line (tube) would rupture during high usage periods.  I would replace the line and it would be good for a day to a couple weeks depending on usage volume.  Had received a nmber of suggestions pointing to possible heat causing reduction in pressure rating of the unloader tube which might weaken the tube and result in failure.  Time passed, pandemic came along, and volume of projects in my shop fell off.

Last month, I again experienced the unloader line rupture failure during a period of high use.  Replaced the unloader tube again and now have a new problem.  The tube will not stay on the 1/4" barb fitting.  Compressor starts normally and at about 80 PSI the tube slides off the barb fitting.  I have replaced the check valve, bard fitting, and pressure switch assembly which includes the unloader valve with no change in symptom.  I am baffled.

Any suggestions / fixes?   

Please Log in or Create an account to join the conversation.

2 years 9 months ago #3563 by Larryd
Replied by Larryd on topic US General Model US66V Unloader Problem
Thought I'd change barb fitting on check valve but having great difficulty determining size.  Anyone have any experience with this? 

Please Log in or Create an account to join the conversation.

2 years 9 months ago #3564 by Larryd
Replied by Larryd on topic US General Model US66V Unloader Problem
The beat goes on.  Tried replacing unloader tube with some from different batch.  Got to about 90psi before tube slipped off bard fitting.  This is starting to be a bit frustrating.  Any ideas from anyone?

Please Log in or Create an account to join the conversation.

Moderators: MTR-Admin
Time to create page: 0.096 seconds